Fresh install Pydio 8.0.2: drag and drop files into macOS browser uploader works but folders do not

This is a fresh install on a brand new Amazon EC2 instance running Ubuntu 16.04 (official AMI image eligible for free tier). The installation was done using the official Pydio repository for Ubuntu 16. Pydio version is 8.0.2 2017-12-13, Community Edition.

Immediately after installation, I attempted to use the built-in browser-based drag-and-drop uploader to upload a selected batch of files and folders to the Common Files workspace on a Mac running macOS High Sierra and Safari (fully updated as of this post’s date).

The files in the the selection uploaded fine. Every single folder in the selection failed with just “Error” as the error message in the window that popped up (not sure what it is called–it has two tabs, STANDARD and REMOTE SERVER at the top).

I can create folders in the Common Files workspace with the New>New Folder button in the web UI and then drag files (but not folders) into the newly-created folder.

The error occurs in both Apple Safari 11.0.2 and Google Chrome 63.0.3239.132 on the Mac.

I created a brand new empty test folder and tried dragging and dropping that up, and it failed also.

No errors show up in the apache2 log nor in the Pydio log.

Then I tested the same process using a Windows 10 PC and Google Chrome 63.0.3239.132 and it worked properly. I was able to drag and drop an empty test folder from Windows File Explorer into the browser-based uploader, and it uploaded fine.

So this error appears to only affect macOS clients.

I’m not terribly inconvenienced by this error but thought it would be good to bring some attention to it.

i’ve tried it with Safari 11.0.2 and Chrome 63.0.3239.132 under mac OS High Sierra and it works properly for me i can drag & drop an empty folder the issue might be related to something else do you mind giving us a link to your server.

Hi, zayn–

Unfortunately, this is a work-related server that has confidential files on it, so I cannot grant anyone other than a handful of authorized employees access. I can log in myself and run tests/diagnostics and report back to you as much as needed.

Thanks for offering, though.

Hi there, I’m having the same issue. Any luck quite yet?

No luck yet. We’re using a Windows PC to do our file uploads for now. I have to figure this out eventually, though, because we do have a few die-hard Mac users.

Ok Sounds good. We’ll keep poking around on our end as well as this is a must for us too. Thanks!

I wonder why it worked for zayn but not us…

Hmm, do you think it could have to do with folder/path length?

Good idea.
I don’t think so, as I was unable to drop folders in the root (top level).
BUT I’ll give it a try again to make sure.

We should also check to see if symbols or spaces in the folder name make a difference.

Confirmed that folder/path length does not seem to be the problem.
I created an empty folder called TESTFOLDER (no spaces, no symbols) and tried dragging it up to the top level of Common Files as the admin user.
I am now at macOS 10.13.3 with Safari 11.0.3 (13604.5.6).

Got the exact same (unspecified) error.

Oh, I found this error in my Safari Console corresponding to the failed drag-and-drop of the empty TESTFOLDER.

Failed to load resource: The operation couldn’t be completed. Is a directory

Good thinking.
Chrome now works properly for me. I am now using 64.0.3282.186 (Official Build) (64-bit).
So I guess this is a browser bug and we wait for Safari to fix it.

At least I can offer a solution to our Mac users now–thanks!

BTW, we are using Ubuntu 16.04.3 LTS and the native filesystem (IIRC, it is ext4). No external mounts–the Pydio server is self-contained.