DD-WRT and Pydio


#1

Greetings everyone,
This might be outdated, but I wanted to get Pydio set up on my R7000 running the latest Kong build.
I followed the instructions for using integrated webs server on Kong’s page.
I currently have it working and I can transfer small files.
But I wanted to increase the size of max upload limit.
Basically this is my problem.
I found this thread as well, but I can’t seem to be able to figure out how to do it.
I’m guessing it’s related to php.ini.
Where is it located?
How do I enable/create it?
Can I use the Github php template for Pydio?
Really appreciate your help.
Thanks.


#2

From what I’ve read the default php.ini is located in /etc folder. php.ini can be placed in /jffs/etc which overrides the default php.ini file and this is mentioned in the routers web interface

Services -> Webserver -> Help -> more

Copy the default php.ini file as root user to /jffs/etc folder

Example - > cp /etc/php.ini /jffs/etc/php.ini

Edit the php.ini that you just copied and set the values you require.


#3

I add:
max_execution_time = 300 (or more)
post_max_size = 1G
upload_max_filesize = 1G
memory_limit = 256 (recommened 512)


#4

thank you gentlemen.
i’ll try once i have access to my system again.
i’m away on a business trip at the moment.