Datasources Are Not Found

Hey :wave:
I just configured Pydio Cells on my Debian Bullseye server and created the admin account. But very soon I noticed that I wasn’t able to create/upload any files.
When I looked into the Console, all of the Datasources were not unreachable:

discord

In the logs I am getting the following errors:

ERROR	pydio.rest.meta	Rest Error 404	{"error": "{\"id\":\"undefined\",\"code\":403,\"detail\":\"Unknown data source\",\"status\":\"Forbidden\"}"}

and

ERROR	Could not find DataSource pydiods1	{"currentSources": []}

and finally, this one :point_down:

ERROR	pydio.grpc.tasks	cannot run action actions.versioning.prune: Could not find DataSource pydiods1	{"OperationUuid": "prune-versions-job-cff11ac4"}

Sorry, I couldn’t link the third log file, because I am a new user :frowning_face:

Log Files

NGINX File: https://pastebin.com/itD6776M
Docker Compose: https://pastebin.com/pCfu0db8
Full Container Logs: _https://pastebin.com/Wtg9UecS

Version Information

Docker Image Hash: b3aa774340bb (latest)
Docker Version: 19.03.8, build afacb8b7f0
Linux Kernel: 5.5.0-1-amd64 #1 SMP Debian 5.5.13-2 (2020-03-30) x86_64 GNU/Linux
Docker Compose Version: 3.8
Database: MariaDB

Any help would be greatly appreciated.
Thank you :smiley:

Hello @vasanthdeveloper,

Reading your logs it seems to point to a wrong peer address on your Datasource.
Could you check if you container ID matches the id displayed in the error 44897b2343ee .

If it does not match the ID could try to edit one of your datasource and re select the peer address with the new id.

Also I read your logs and saw

Activating privacy features... done.
https://0.0.0.0:8080
#[server name]

I assume that you use the 0.0.0.0 on the bind address, would you mind trying with both the BIND and EXTERNAL with the server ip/domain_name.

1 Like

Thank you so much for taking the time to help me. :smiley:

Sadly, I have removed and recreated the docker containers many times after I posted this tread. So, I cannot verify if the container IDs were correct.
But I did try to completely re-install Pydio Cells from scratch with internal URL pointing to my external domain.
But that seems to break the NGINX reverse proxy, here are the container logs for this time.

I am a little curious about why this error occurred where it wasn’t there previously:

ERROR   pydio.gateway.proxy Could not run   {"error": "error inspecting server blocks: [https://cloud.vasanthdeveloper.com:80] scheme and port violate convention"}

Log FIles

Full Container Logs: https://pastebin.com/7CZ5ziDA

If i’m not mistaken this error is telling you that you cannot use port 80 with the scheme HTTPS, you should try with any other port or else you can try with http.

I would like to serve the user with port 80 and have TLS. Is there any specific reason this isn’t allowed?

Status Update

I have changed the image from pydio/cells:latest to linuxserver/pydio-cells:latest and those errors were gone. With minimal to no configuration I could get Pydio Cells to work.

Thank you @zayn for helping me. :smiley:

Hi
I solved this problem. Maybe new container restarting happened this problem.
If you use docker container and official image(pydio/cells), you should set hostname.

version: '3'
services:

    cells:
        image: pydio/cells:latest
        hostname: pydio ★←add
        restart: always
        ports: ["8080:8080"]
        environment:
            - CELLS_BIND=files.example.com:8080
            - CELLS_EXTERNAL=https://files.example.com:8080
       volumes: 
            - "cellsdir:/var/cells"
            - "data:/var/cells/data"

    # MySQL image with a default database cells and a dedicated user pydio
    mysql:
         image: mysql:5.7
         restart: always
         ports: ["3306:3306"]
         environment:
             MYSQL_ROOT_PASSWORD: P@ssw0rd
             MYSQL_DATABASE: cells
             MYSQL_USER: pydio
             MYSQL_PASSWORD: P@ssw0rd
         command: [mysqld, --character-set-server=utf8mb4, --collation-server=utf8mb4_unicode_ci]
         volumes:
             - "mysqldir:/var/lib/mysql"

volumes:
    data: {}
    cellsdir: {}
    mysqldir: {}

Hello @lottotto,

Thank you for your help, indeed setting the hostname is the right way, I"ll create a ticket and will update the documentation accordingly.

1 Like

Oh, that’s awesome! But currently I am in-between a scheduled maintainance of my workstaion. I will try this out as soon as my system are up and ready :smiley:

1 Like