Configure S3 Bucket as Default Workspace


#1

Hello,

I’m using the latest community edition installed on Ubuntu1604 on AWS.

I would like to configure an S3 bucket to be used as the default Workspace for users, and enable sharing.

For all my trying I’m hitting a brick wall and I’m sure I’m missing something simple, and so I hope someone can help me get this running.

I can add the S3 bucket as a Workspace, that works. I can also then set it as the Default Workspace for a user. It is then shown to the user when they log in to the Web app, however it does not show at all in the Desktop client under ‘Remote Workspace’ when signing in.

And finally, if we attempt to share a file from this S3 workspace, the box flickers but the “Enable Public Link” checkbox remains unticked.

Where am I going wrong?


#2

Hi,

make sure that output_buffering is off, it’s a php parameter.

try to add Syncable metaplugin and lucene search engine to this workspace.


#3

Hi Zayn,

Thank you for the suggestion, output_buffering appears to be off as default:

; output_buffering
;   Default Value: Off
;   Development Value: 4096
;   Production Value: 4096

I added the Syncable metaplugin and lucene search to the Workspace and that did indeed let it be seen in the client, although I now get “Unexpected Error: No JSON object could be decoded” on the client.

Public sharing links remains broken.


#4

Hi,
you have to uncomment it though ( if you didn’t of course) .


#5

Hello,

Yes that’s uncommented, still does not work.

If I attempt to share a file from ‘My Files’, that works as expected.


#6

Hi, Try to look at value of output_buffering. Its default value is not “Off”


#7

Dont forget to launch the indexation at the first time before connect this workspace by desktop sync / mobile app


#8

Thank you all for your input and suggestions, very much appreciated.

In the end I gave up and just mounted S3 as a filesystem, it all works excellent now.


#9

Hi,
sorry for misleading you but as c12simple told you the output buffering that you need to change is this one

it’s by default 4096, so you just have to write off.
If you want to try one more time.