Configure Personal Files as default workspace


#1

I cannot assign “Personal Files” as default workspace as shown in the screenshot below.


#2

Hi,
could you tell me your pydio version,
also i would like to know when did it happen, and did you change a specific setting?


#3

Hey,

I’m currently running version 1.2.4, Only updated from 1.2.3 earlier since some command line resync triggers were broken. But its basically a fresh install otherwise, i’m replacing an old Legacy Pydio with a new server/new instance of Pydio (Cells). Now I’m seeing there is update to PydioHome 1.2.5 available. But basically, I’m looking at final tune-ups before going live with it and I realized it was impossible to set the default workspace to Personal Files globally on the Root Group Default Workspace. But on the other hands, I can set it from within each user account, which is cumbersome.

Thanks,

Yannick


#4

Just so you know:

#1 - I updated to version 1.2.5. Issue still occurs.
#2 - I updated to version 1.4.0. Issue still occurs.


#5

Strangely enough, here are the available options I see when setting the default workspace from the admin


#6

Versus what are the available options from within the users’ account

Hope it helps figuring it out

Thanks,

Yannick


#7

Oh God, I had an Eureka moment. I’ll let you decided if that’s an actual issue or not.
But basically, here’s our use case:

We’re an Ad-Agency and we’ve got one account per clients and one master account we use to get/push data to clients account folders. So all client accounts lands on Personal Files Workspace.

I’ve also created another workspace which gets to the root of personal files’ workspace and give read/write access to it. This enables us to have access to all our clients data without using their credentials.

But since I wanted to prevent people internally using the main account from pushing files to our Personal files workspace, I deny access to it. Which is why I wasn’t able to select it from the default workspace selector option. Even though the main account is an administrator account.

#FoodForThoughts

Thanks,

Yannick


#8

Hi Yannick
Deny always wins :slight_smile:
Maybe you can configure in the other way round: remove all rights from the “root group” role, and open accesses to specific users (avoiding deny).
-c