Collabora online installation with docker

Please provide the following tags: install / upgrade, package type, server OS, pydio version

Hello everyone,

i’m trying to install collabora/code with docker on a debian 9.5 server with pydio 8.2.2,php 7.0.33 and apache2
I installed Pydio 8.2.2 according to the instructions of my colleague because they v’e already pydio on a server but it’s an older version.
They want me to install pydio (done) on a server and now they want collabora for editing documents.
I have to do this in test, not in production.
But i don’t understand all the specifications of this installation with docker.
My server has a domain like and it’s recorded on the dns server.
An cname record like was created and i followed the instructions steps on the official guide.
I’m using a self signed certificat and i use the docker command :

sudo docker run -t -d -p -e ‘domain=blo\.blabla\.fr’ --restart always --cap-add MKNOD collabora/code.

But it doesn’t work and i can’t see the plugin in my pydio parameter.

¨I wish you could help me

Thanks you

to use the collabora plugin on Pydio 8 you must first enable it and then configure the parameters,
you can find the plugin in Available Plugins > Editors > Collabora Online, enable it and then you can click on the pen on the right to configure,

it’s the problem, i can’t enable it because collabora plugin is not available.

In fact, i 've got some errors when i use sudo docker logs --details idcontainer

wsd-00029-00030 2019-02-08 10:26:36.549270 [ prisoner_poll ] WRN ForKit not responsive for 127873 ms forking 1 children. Resetting.| wsd/LOOLWSD.cpp:427

wsd-00029-00052 2019-02-08 10:33:56.926182 [ websrv_poll ] WRN client - server version mismatch, disabling browser cache.| wsd/FileServer.cpp:279

First look for editor.libreoffice folder inside your pydio installation under plugins/editor.libreoffice.

If you think you are missing the plugin,
you could download the archive,
and take inside plugins this folder editor.libreoffice, copy it to your pydio plugins folder, refresh cache (restart apache to also be sure) and check back if the plugin reappears.

thanks for your help.
The plugin appeared and i enabled it with you advises.
Now i have a problem with self signed certificat and i can’t edit documents.
But i think it’s an another problem with my network.

your welcome,
let me know if you have any other issue.