Chrome autocomplete issue

chrome
#1

Pydio version: 6
Server OS: CentOS7
Install: yum install

I use pydio with Chrome, and If I enable autocomplete(id/password) in my pydio homepage, my saved ID in Chrome is typed automatically in ‘search form’ of initial page after login.

See below image(‘shim1st’ is my ID).

How can I fix this problem?

Chrome is latest version.

#2

I found javascript(/usr/share/pydio/plugins/gui.ajax/res/js/pydio/ui/class.SearchEngine.js) and modified search form tag like style=display:none and autocomplete=off

If I want test it, Do I have restart httpd service?

How can I apply new java script?

#3

Hi,
for that you would have to edit the js file, then npm install && grunt to rebuild your pydio with the new JS.

#4

Is it effective in Pydio version 6?

Sorry but I don’t have any knowledge about node.js.

Warning occurred with ‘no package.json file’.

#5

yes,
if you know what you want to change it is,
now for your autocomplete issue you should look for a way to disable it on a specific page on the browser.

#6

In “gui.ajax” folder, there is no package.json file, so “npm install & grunt” command doesn’t work.

And my issue is only occurred in recently version of Chrome.

How can I apply modified ‘class.SearchEngine.js’ file without restarting httpd(not grunt environment)?

#7

This issue only occurs below environment

  • Latest version of Chrome
  • Pydio User setting: select default workspace(anything but HOME).

How can I recompile(repack) “ajaxplorer.js” file in “…/plugins/gui.ajax/” ?

I don’t use grunt…

#8

Pydio 6 is deprecated. Please update to latest version

#9

Hi, I have the same problem

When I add -> style = “display: none” autocomplete = “off” in the code

The search bar disappears.

#10

But that solves the problem of space with folders / files

And that masks the search bar so it does not solve the problem

Do you have any idea where the problem is coming from?

Thanks for your help.

#11

Hi,
your issue seems to arise with the latest version of Chrome,
could you tell me the exact version of your browser and also does it happen with firefox for instance?

#12

Hi there,

Thanks for the reply.

I’m working with hmanuel, is off. We are using Chrome 71 currently, not the latest. It’s not happening on Firefox. It is also happening with latest Chrome version.

Hiding the search bar is not the ideal workaround.

We dig a bit https://developers.google.com/web/fundamentals/design-and-ux/input/forms/#recommended_input_name_and_autocomplete_attribute_values but not much help.

Thanks

Simon

#13

Is this bug present in version 8?

#14

Hello, we use version 6 of pydio as @sim1st where the beug is present. Using the Chrome 71 using as @simong said.

@sim1st Did you find a solution to solve this problem?

#15

Not yet.

I couldn’t test modified javascript because I don’t have test environment(grunt).