App crashes on Android when uploading a file bigger then 200mb

The android app crashes when I try to upload a file bigger then 200mb, when the upload data exceeds 200mb the app crashes. It’s fine on the web, with a browser i can easily upload a 2GB file the problem appears only on the android app (android 10 OneUi 2.1)
The php.ini files upload limits are set to 10G Soo that shouldn’t be the problem, i can provide a video if it’s needed

Hello @Alles and welcome to the forum.

If your server is still in P8, as I am guessing, this is most probably caused by a known issue with the internal management of the events that are used to display a progress.

This is fixed in the next version that will be soon published.

A side question yet: this next version is a major rewrite of the app that is almost 10 y.o.: we had to get rid of a lot of legacy code and refactor many things to be ready for further improvements. So there might be some glitches. Would you be interested in testing a alpha release ?

Hello @bsinou,
thanks for you answer. I ran in the same problem like @Alles described.

Using the Android Pydio App
Version name: 2.3.3
Version code: 44
Version date: 2021.06.07

The server is a ARM64 Version:
Pydio Cells Home Edition 2.3.1-dev.202107300620
Released : 2021-07-30T06:29:15
Revision : 44df03fbdead2143aa5743e64a13110097d1ae75

Tried several versions with the same result.
BTW: Where can I get a ARM64 stable release?

Since I’m not on P8 the problem should’nt occurre?
Any idea how I could solve the problem?

Hello @coloeus and welcome in our community.

You have the same symptoms, but maybe not the same cause:

  • it is either the same issue that comes from the progress bar and that should fixed in next version
  • or this is a simple time-out during the upload, multipart is not yet implemented in the Android app.

So a few questions:

  • Could you please precise the size of the file you are trying to upload?
  • Do you see any logs on the server side when you try to upload?
  • Would you be interested in downloading / installing a test APK to see if the new version of the Android app solves your issue?

We plan to add the ARM builds in the next major release of Cells (v3, that should go live in a month or 2: 2.3.x releases are in fact alpha versions for the v3) but we still want to make some testing before doing this.
Until then, you are stuck with the dev builds.
By the way, have you seen any ARM specific issues with your instance or is it running glitch-free ?

Just for the record, the Android link for the test App on the store is: https://play.google.com/store/apps/details?id=com.pydio.android.Client

Yeah, i would like to try the new alpha application too see the improvements

The pre-release is in open testing mode on the store.

You might also directly download the APK from our download site;

https://download.pydio.com/pub/apps/android-client/releases/2.4.0-alpha/Cells-2.4.0-alpha.20210729.1843.apk