Android app "unable to reach the server"

I have been unable to connect the Pydio Android app to my server ever since the change from ajaXplorer. I have never put the time into trying to sort it out until tonight, and it just will not connect. I am running the latest server version (8.0.1) on a Windows 10 machine using XAMPP as my web server for Apache (and other additions). I have a valid SSL certificate installed from and it has been verified as working properly. The web interface works great and is what I almost always use. I uninstalled the Android app and installed it fresh tonight from Google’s Play Store. The most current version is 1.7 and has apparently not been updated since October 9, 2015 (ouch…don’t forget us). I select “https://” and then type in my server name and the correct username and password. I am not checking the two boxes (self-signed cert and legacy access) though I have tried both of those options while troubleshooting.

It says:

“resolving home…”

then it says:

Unable to reach the server. you have set “https” protocole, maybe you should check “SSLselfsigned” option

(also there is a typo in the error…should say “protocol”…with no “e” at the end)

I have tried adding a forward slash at the end of my server address but that did not help. I have tried http, self signed, and legacy access. Nothing seems to work.