Zoho is not working

Hey there,

I’m running Pydio 8.2.3 on an online server.
I try to use Zoho but I got these error whein trying opening a file :

Client error response [url] https://exportwriter.zoho.com/remotedoc.im [status code] 401 [reason phrase] Unauthorized

or

Server error response [url] https://sheet.zoho.com/remotedoc.im [status code] 500 [reason phrase] Internal Server Error

It’s been hours that I try to make it working.

Here is some logs from the server :

“GET /index.php?secure_token=####&get_action=post_to_zohoserver&file=####=&parent_url=####== HTTP/2.0” 401 201 “https://####/ws-default/” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.157 Safari/537.36”

And I only got this error but I don’t think it’s related :

AH01276: Cannot serve directory /####/: No matching DirectoryIndex (index.php,index.php5,index.php4,index.php3,index.perl,index.pl,index.plx,index.ppl,index.cgi,index.jsp,index.jp,index.phtml,index.shtml,index.xhtml,index.html,index.htm,index.wml,Default.html,Default.htm,default.html,default.htm,home.html,home.htm,index.js) found, and server-generated directory index forbidden by Options directive

Do you have any tips please ?

Thanks !

It should be problem of api.

Please verify api string and its validity.and set plugins/editor.zoho/agent writable for apache

Hey,

I generated a new api and same problem.
The website to generate the API is : https://officeapi.zoho.eu ?

Because the link in the doc is dead.

I set 777 for testing and it’s not working.

Thanks for your help

Hi,
Do you have default .htaccess (https://github.com/pydio/pydio-core/blob/develop/core/src/.htaccess) ?
what do you have in result when you browse http://domain//plugins/editor.zoho/agent/save_zoho.php ?

Hey,

Yes it was the default, I remplaced it by yours anyway.
It redirect the http to the https and it’s a blank page.

Still not working :confused:

Thanks

edit : I installed Pydio with cpanel ( Softaculous Apps Installer ) because I didn’t achieve to install it manually. Do you think it can be that ?

New edit : installed Pydio manually, and have the same problem.

is “allow_open_url” is enabled or somthing may block request to zoho server !?

Hello. Yes it’s enabled…

I don’t understand why it’s not working. I guess i’ts because my server is mutualised and maybe there is security reason that I can’t overpass.

I leave Zoho, I will find another solution ( I installed with success etherpad on my server )

But I have another problem. Maybe you could help me : Shared link : blank page

I guess it’s related, problem of right access ?

Thanks a lot for your help anyway !