Invalid client credentials using REST API


#1

Hi guys,

We have an issue to get a token with auth.

curl -X POST 'http://localhost:8080/auth/dex/token' \
-u xxxxxxxxxxxxxxxxxxxxxx:xxxxxxxxxxxxxxxxxxxxxx \
-H 'Cache-Control: no-cache' \
-H 'Content-Type: application/x-www-form-urlencoded' \
-d 'grant_type=password&username=yamil&password=password&scope=email%20profile%20pydio&nonce=nonce'

We get this response:

{"error":"invalid_client","error_description":"Invalid client credentials."}

And we don’t know if the API Token and API Secret that we are using are corrects?


#2

I resolved with:

cells-enterprise config list

Then, rather than use the API Key and API Secret from my pydio.com account, I use the ID and the Secret showed above.

In the documentation specs don’t tell us how to get this values, Pydio team should update the documentation.


#3

Hi,
could you show me this part of the documentation, i will update it.


#4

Sure. https://pydio.com/en/docs/cells/v1/using-rest-api

In the section:

The API_KEY and API_SECRET are required to perform any request. They can be found in " Configs Backend " in the admin settings.

It should be:

The API_KEY and API_SECRET are required to perform any request. They can be found using the command cells-enterprise config list.
You should use Id for the API_KEY and Secret for API_SECRET under the pydio.grpc.auth service section.


#5

I will update this section asap.


#6

Could you update this in the cells home edition as well? It still says

The API_KEY and API_SECRET are required to perform any request. They can be found in " Configs Backend " in the admin settings.

but I had to use cells-front as the key and the api secret listed in ./cells config list


#7

Hi,
sorry i actually forgot to update the site, i pushed the modification a while ago on github but i forgot to update the site itself (repull the updated repo), will do that right now.