Docker, local installation, fresh install... nothing works, Pydio freeze on loading


I 've been trying to install Pydio on docker because I want clears docker containers for all my services, I ran it on 8080 made a simple reverse proxy like I would with drone and it worked, I was able to use the web installer but when the installation finished after the reload it freezes on the grey loading page…

I’ve tried without docker with a fresh install and same, I can run the web installer but it freezes on the loading.

Here are more details about my config:

Using a VPS,
Ubuntu 18.04 (bionic),
latest pydio cells,

what I wanted to use (for ips and all):
EXTERNAL: https://,ui.:8080/

Also I’m using Cloudflare I don’t know if it matters…

When running on docker I cannot check the logs, but when running locally, in the logs I get “Frontent service not started” error and even doing ./cells start pydio frontent doesn’t fix the freeze.

Hope you can help me with that.

EDIT: I also use NGINX as my web server locally and not in a docker container

Hello @Nepmia and welcome in the forum.

The grey “loading” page is in fact a static background that is first loaded before the real javascript UI is there.
Usually, if it stays stuck there, it means that you cannot download the JS web GUI.

Most probably because you have a CORS issue. You should have a look at the dev tool from your browser. And from the info you have provided, it seems like your EXTERNAL URL is unvalid:
https://,ui.:8080/ seems kind of weird.

For the external URL you have to use a real DN name like it is the URL your end users will use to connect to your server.

And by the way, you should also insure that your docker container can reach itself using this public URL. It is a limitation that we are aware of and that will be removed in next minor release (2.1.0) that should come out this month.

HI @bsinou,

Thanks for the welcome.

About the external url, I don’t know what happenned in my head but it’s totally not the url I’ve setuped, I have


The docker container should work, I will reinstall everything and take a look on the network tab.

Just in case I still get issues could you give me a proper docker-compose I could use?

Thanks for you answer and have a great day.