Cells does not recognize files/folders created directly on storage

When I create files or folders directly on Cells storage and even if I run
cells admin resync --datasource=personal
afterwords (both with cells started or stopped) I get Resync Triggered but when I access my area the folders I have created do not appear there.

Furthermore when I do an Upload files or folders are create on cells but upload never finishes and they never appear on the storage.

I am using Cells 3.0.6 with a reverse proxy setup under WAMP with Apache 2.4.41, PHP 7.3.13 and Mariadb 10.4.13 in a Windows 10 server.

Any help is most welcome

Hi,

Please note that in v3, the datasources are created by default using a flat structure. Meaning that we only keep the file structure as an index in the database and files are stored as objects on the disk. A resync will not do much. To be able to use structured datasource that keep in sync the data structure on the disk and the database, you can install cells using the CELLS_DEFAULT_DS_STRUCT=true environmment variable, or create a new datasource in the Cells console and select the Import Existing Data option.

As for the upload that never finishes, do you have any specific error, either in the browser or in the logs that could be helpful ?

Thanks,
G

Thanks @ghecquet your workaround worked and now the structure is updating. Concerning the upload problem it persists and I wonder if it is related with

Furthermore I I checked the database and noticed that

Every time I start cells I get two errors that might be relevant

2022-04-28T08:30:56.401+0100 ←[31mERROR←[0m ←[35mpydio.grpc.data.index.thumbnails←[0m Failed to init DB provider {“error”: “Error 1060: Duplicate column name ‘name’ handling data_index_thumbnails_idx_0.2.sql”}
2022-04-28T08:30:56.466+0100 ←[31mERROR←[0m ←[35mpydio.grpc.data.index.thumbnails←[0m Could not run {“error”: “Error 1060: Duplicate column name ‘name’ handling data_index_thumbnails_idx_0.2.sql”}

I looked in the cells folder and I could not find the file
data_index_thumbnails_idx_0.2.sql

The structure of data_index_thumbnails_idx_??? databases are

Is there a way of fixing this problem?

Thanks