Andoid APP Link is wrong

Hey! :slight_smile:
I have a small-medium Problem with the Links for sharing on the android app.
Every time i share a link with the official pydio android app i get a wrong link.

it should be:
but i get:

so it seems he put my base domain in front of the link.

someone has an idea? thanks! :slight_smile:

Hi @Christian_L

thanks for the feedback. Could you please precise the version of the android app you are using?

We are currently beta testing the new version of the App that should be out soon, there are still a few glitches but it should already be much better that the one that is currently in production.

Could you opt-in in the play store to be beta tester and give it a try?


Hey! Shure:

Client for Android
Versionname: 3.0.5
Version Code: 132
Versiondate: 28.04.2023

i will try it with beta :slight_smile:

Ok, thx for the info.

For the record this is a known issue in v3.0.x:

Versiondate: 28.04.2023

It is not the timestamp of the release, rather the date on which you installed it on your device…

okay! i got the beta update now:
Version Name: 3.1.0-beta2
Version Code: 159

But sadly the problem still exists.
And it doesnt matter if a generate the link or try the share funktion to automatically put the link in whatsapp.
In all Cases the link has my base domain in front of the link.


OK, thanks for the info, we will have a look and try to fix this in the next beta that should be out this week.
I’ll let you know if we need more details.

After quick investigation, we could not reproduce.
Could you please tell the version of the Cells server you are trying to connect to?

Did you configure the external URL of the server?
see: Manage Sites | Pydio

Workaround: Set the default domain of public share links.


I am the colleague of Christian.

Our installed server version is 4.1.2, built on March 23, 2023. Git commit: 6326c5f218f93bf9c55e377ab92f639ecfea24d3. Go version gol.19.7.

When we generate a public link with iOS devices or/and in our browsers its doing what it should do :slight_smile:
Only when we want to create a public link from android devices we have that behaviour.

We did not configure an external URL on the cli side, and the default domain of public share is set to the bind url per default.


in URL to generate publik Links we filled in β€œ”

you mean this?
whats your recomendet change?

Make sure you have set an external URL and a URL to generate public links.

I rather think that setting the URL for the public link (the last field in the bottom right corner of the App param >> Main Settings page of the console) was the cause for this behaviour.

Anyway, it should be fixed in the beta3 that we put in the beta part of the store yesterday.
If anyone would mind to test, it would be appreciated :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.