Pydio Cells Storage on another Server

@dweimer I’m having the exact same issue. Did you ever find a solution? Thanks

Nope, I haven’t been able to get past it, rebuilt entire server, reinstalled debian linux and everythign from ground up. still have same problem. System can browse files, but I am unable to access it through Pydio. I can browse to the folder on the storage section but when I try to add the workspace it returns an error. Even though its browse able in the drop down list, the backend api doesn’t seem to have access to it.

2018-06-14T09:12:16.857-0500 ERROR Could not find DataSource workstation {“currentSources”: [“cells”, “personal”, “pydiods1”]}
2018-06-14T09:12:16.880-0500 ERROR pydio.rest.frontend message=[404] Error connecting to the API (https://pydio.dweimer.net:9443/a/tree/admin/list) {“FrontIp”: “10.20.130.5”, “UserId”: “dweimer”, “WorkspaceId”: “settings”, “Source”: “ApiClient.php l.287”, “Nodes”: []}


Think I found something, thought maybe a restart of the server after adding the workspace would help. But I did see this error, its refusing to cross the mount point.

time=“2018-06-14T09:28:45-05:00” level=fatal msg=“Invalid command line arguments server=‘:9001’, args=[/smbfs]” cause=“Cross-device mounts detected on path (/smbfs) at following locations [/smbfs/workstation/Downloads]. Export path should not have any sub-mounts, refusing to start.” source="[server-main.go:96:github.com/pydio/cells/vendor/github.com/pydio/minio-srv/cmd.serverHandleCmdArgs()]"

Hi,
on your previous screenshot i see that downloads in highlighted in red and that’s because you cannot use Caps, try to renamed it to /downloads and you should be able to select it from the interface.

I did rename it at somepoint after seeing a different error, it currently all lowercase and still fails to start showing the mountpoint error.

2018-06-18T07:51:20.099-0500 INFO pydio.grpc.data.objects.local2 Starting objects service local2
time=“2018-06-18T07:51:20-05:00” level=fatal msg=“Invalid command line arguments server=‘:9001’, args=[/smbfs]” cause=“Cross-device mounts detected on path (/smbfs) at following locations [/smbfs/workstation/downloads]. Export path should not have any sub-mounts, refusing to start.” source="[server-main.go:96:github.com/pydio/cells/vendor/github.com/pydio/minio-srv/cmd.serverHandleCmdArgs()]"

Hi Dean,
this is currently a limitation of Cells - We are starting a minio server to serve the file using http protocol, and minio is limiting this on mounted folders. We are working on that for direct smb/cifs mount. Or you can try using a docker volume with tool : http://netshare.containx.io/ and mount your smb share directly inside docker. I tested that recently and it was working (minio sees it as an standard folder inside the docker).
Charles

Are minio datasources yet working with cells? I have an external-to-cells minio server but cannot seem to figure out the correct parameters to input for S3 in the “Datasource” screen. In reading the official documentation I also cannot figure it out. When I input what I think should be the correct parameters for my minio server, the result is: “Objects service down”. However, when I go to Settings->Services, I only see green lights for both objects and for the minio Storage I created.

1 Like

hi @v60fan
Could you maybe post the config you use for this datasource? Switching to S3 datasource type with the correct endpoint url and api key/secret should work with an external minio server, indeed.
Charles

Sure. Is this what you mean?

DataSource identifier: minio (I think this is just a label, so doesn’t matter too much)
Enabled: switched to on
Internal Port: 9001 (left as default)

Storage Type: Remote Object Storage (S3)
Bucket Name: cells (I created this bucket in the top level of my minio server)
S3 Api Key: [the same one I use in my config.json for minio] (I’m certain this is correct)
S3 Api Secret Key: [the same one I use in my config.json for minio] (I’m certain this is correct)
Internal path: [left blank] (I’m not sure if I’m supposed to fill anything here or not)
Custom endpoint: https://s3.mydomain.com (set to a real URL, and it’s the base URL for the minio service)

1 Like

Humm, params seem ok.
Can you have a close look at the log when you start cells ? Do you see errors regarding this datasource ?
Charles

Hi @charles so that I could follow the log, I have restarted the cells container (I’m running in docker and I’m also using a traefik reverse proxy for SSL termination).

I do see a couple types of error:

First is:
level=fatal msg="Unable to initialize gateway layer" cause="Unable to initialize event notification. Get https://s3.mydomain.com/: x509: failed to load system roots and no roots provided" source="[gateway-main.go:357:github.com/pydio/cells/vendor/github.com/pydio/minio-srv/cmd.gatewayMain()]"

And then I also see:
ERROR pydio.grpc.data.sync.(.+) Could not run {"error": "objects not reachable"}

1 Like

is the external minio served on self-signed ?

No, it’s valid LetsEncrypt SSL

@charles are there any news on this limitation?
Without the possibility to add nfs/smb remote storage pydio is pretty much useless to me.

Until it is possible, could you please mention this in the documentation?

1 Like

@v60fan at the end of the day, did you get it?

I was trying to configure Minio with Pydio

But what I get is objects down

No, I wasn’t able to overcome the issue I had above. I ended up giving up.

I have a similar issue of the “cross-devices mount” detailed here: Error while listing on creation or resync of a DataSource

I succeed to get past it but was block on the next step, that is building the index (the storage exist, the workspace as well, but I cannot list anything inside for some obscure reason.)
I’m waiting for support as well, it seems pretty basic use case so I hope we’ll find a solution (it was working as is in pydio server from version 5 to 8).

wait&see

Hi,

here’s my minio configuration if it can help(my minio is running on another server with the 109 ip)
usually you should atleast check that you can access it through URI,

edit: could you tell me what cells version are you on right now and also are you reverse proxying?

This are my settings:

40 08

Minio version:

➜  cells git:(stable) ✗ minio version
Version: 2018-11-17T01:23:48Z
Release-Tag: RELEASE.2018-11-17T01-23-48Z
Commit-ID: 7b579caf686110d96349ec4e90beacf7eed5af89

Cells version:

github cells with stable branch

And I’m not using reverse proxying