Pydio Cells Install : panic: runtime error: slice bounds out of range

Downloaded your Pydio Cells v1.2.5 release from your website,
Later, I build Dev version on my Ubunut 18.04 development desktop.
All attempts when running from a newly created pydio account result in this Go Panic
Tried various ideas to see it I can locate issue. Running the build of cells from within the source directory does get me a little further.
I’m confident I am following your install instructions…
But I guess it’s missing some dependencies.

Please advise

pydio@z390ma:~$ ./cells version

    Pydio Cells Home Edition (1.2.5)
    Published on 09 Jan 19 16:11 +0000
    Revision number 50df9a4dfd6f61dc6f2733a3376e2e834690ce33

pydio@z390ma:~$ ./cells install

Welcome to Pydio Cells Home Edition installation
Pydio Cells Home Edition will be configured to run on this machine. Make sure to prepare the following data
 - IPs and ports for binding the webserver to outside world
 - MySQL 5.6+ (or MariaDB equivalent) server access
Pick your installation mode when you are ready.

✔ Browser-based (requires a browser access)
Use the arrow keys to navigate: ↓ ↑ → ← 
✔ External Host (used to access this machine from outside world if it differs from Bind Host):✔ External Host (used to access this machine from outside world if it differs from Bind Host):
✔ Disable SSL (not recommended)
panic: runtime error: slice bounds out of range

goroutine 1 [running]:, 0x18, 0x0, 0x0)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x2ac, 0x0, 0x0, 0x0)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0xe5, 0x69ffc10, 0xc4232124c8)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x22, 0x0, 0x0)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0xad, 0x0, 0xc423212560)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x26, 0x13, 0x33f887b, 0xe, 0x0, 0x0, 0x0, 0x0)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x39, 0x13, 0x33f887b, 0xe, 0x3, 0xc420060f70, 0xc420060f00, 0xc42009d318)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x61, 0x13, 0x33f887b, 0xe, 0x0, 0x98, 0x3185220, 0xc4247cbad0, 0x100000000000000, 0x0)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x56*VaultSource).initMasterPassword(0xc4244dd540)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0xe7, 0x30, 0xc42452eae0, 0x2f, 0x0, 0x0, 0x0, 0x0, 0xc423212830)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x19d
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x398
sync.(*Once).Do(0x8b451e0, 0x69fdd78)
	/usr/local/go/src/sync/once.go:44 +0xbe, 0x2bc1b80)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x39, 0x841fc40, 0xc42454ef30, 0x3, 0x3)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x183, 0x33e7282, 0x8)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x1490, 0x0, 0xc4209eba10, 0x29)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x92a, 0x8b45110, 0x0, 0x0)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x2039*Command).execute(0x8967f00, 0x8b45110, 0x0, 0x0, 0x8967f00, 0x8b45110)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x2c1*Command).ExecuteC(0x8967320, 0x1, 0x1, 0x69fe570)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x30a*Command).Execute(0x8967320, 0xc4200b6058, 0x0)
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x2b
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x36
	/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x6a

yes it could be that,
when you use make dev does it ask you for dependencies such as packr?

@jradxl i forgot to ask but do you have a private address.

Seems like an issue with dbus, which is a tool for storing secret data in a keychain on the server. Can you check whether it is installed or not on this ubuntu?

This honestly happened to me too, and I accidentally found out what happened.

I followed your instructional step-by-step at the following link:

But when I went to install, it wouldn’t let me. I tried it multiple times as the standard user, before I decided to run through the steps again.

So here’s all I did different and it worked:

After creating the user “pydio” and creating the MySQL database, and downloading and installing Pydio Cells at the newest version 1.6.1 (for Ubunutu 18.04 LTS installation), I switched to the root user with the command “sudo -i”

I then changed directory with: cd /home/pydio and then I ran “su - pydio” and then ran the ./cells install command, and the install went through clean. No panic error.

For some reason, running pydio as my standard user with elevated privileges (typing sudo before each command) wasn’t good enough. I had to be running as root, from the proper directory before I could run the command to su - pydio and ./cells install.

Hopefully this helps some others.