Error listening on router port: 5222


#1

Hi,

I tried to install cells on another machine. Since ejabberd uses port 5222 on it, unable to install cells. When executing ./cells install, it reported an error.

2019-01-26T01:26:36.847+0900	FATAL	Error listening on router port: 5222 - listen tcp 0.0.0.0:5222: bind: address already in use

How can I fix this issue?


#2

Hi,
let me ask the devs if it’s possible to work around that.


#3

In this time, I changed ejabberd port settings, however, I’d like cells to come to be able to change its bind addresses/ports if possible.


#4

ok,
but this 5222 port was it the port that you used for your bind, external?


#5

Yes, port 5222 is generally used by XMPP protocol


#6

Hi,
sorry for the late answer so this port is used by default by nats,
you could change it but only after you have installed cells, so you atleast need to change your XMPP port during Cells installation.

if you use ./cells --help you can see below,
all the flags and the ports that you can change.


#7

Oh, thanks. I missed it.