[solved] Unable to install Cells V2

Can you try to use the LE Staging CA URL (the Do you want to use Let's Encrypt staging entrypoint? question during install) ? If it works, this will probably confirm the domain is banned (for a week…)
If it is confirmed, see https://letsencrypt.org/docs/rate-limits/

Yeah sure, will give the DNS an hour to propagate the IP change of a new Droplet.


Unfortunately it’s the same outcome.

This site can’t provide a secure connection
sub.domain.com sent an invalid response.

The caddy log is still empty by the way.

Alright, bought a SSL Cert now, let’s see if that’ll work.

So after trying out a separate SSL, I get the following error:

421 Site sub.domain.com is not served on this interface

However SSL is enabled.

  "cert": {
    "proxy": {
      "certFile": "/etc/ssl/certs/sub_domain_com.crt",
      "httpRedir": true,
      "keyFile": "/etc/ssl/private/sub_domain_com.key",
      "ssl": true


"defaults": {
    "database": "c08dbff4672e09fb31daf312a645bf54694e5f61",
    "datasource": "pydiods1",
    "url": "https://sub.domain.com",
    "urlInternal": ""

Caddy error log is still empty

This worked wonderfully with a NameCheap generated SSL.

I changed internal to and added my external url in the hosts file. I suppose that is a requirement and not documented very well.

Either way I’ll give this a spin now and see if I can get an article written to help other people get this setup with less hassle than I’ve had.

So, almost at the goal. S3 doesn’t seem to work.

It creates a .pydio in the bucket correctly, but whenever I try to upload something via the UI, I get a
cannot run action actions.images.thumbnails: personal/username/image.jpeg: The specified bucket does not exist:

Which I don’t understand, as Pydio has just placed a .pydio file in the bucket.

Have you experienced this before?

It’s in a somewhat odd state of being both uploaded and not:

On the main-screen the images look fine, but once I click on one of them it goes into indefinite loading:

Main Screen:

Clicked on 128.png

And after writing all this, they’re still loading in my other tab.

The Cells Sync also seems to be having some issues:

Also getting an unable to connect from the mobile-app, albeit it can fetch the certificate and asks me to acknowledge it.

I had to adjust the /etc/hosts file as well in one of my cells server test setups (lxc container on proxmox). But then I realized that the server couldn’t resolve my domain. After setting a dns server manually, everything worked without having to change the /etc/hosts file.

What is your set up? Cells server with ssl enabled behind a caddy proxy? And with S3 buckets?

Yeah, with a purchased SSL cert, as LE didn’t seem to want to play ball.

Hello @JapSeyz,

If you don’t mind cleaning (rm -rf ~/.config/pydio/) and reinstalling with the following:

  • INTERNAL: domain:port
  • EXTERNAL: by default should have scheme:domain (nothing to change if you are not running behind a proxy).

Once it is done could you try the sync with a regular workspace.
Also recreate your S3 datasource and tell me if you have any issue.


Will give it a go when I get home.

Can I simply delete the config and then run the installer again?

Yeah it’s pretty much that, (make sure to clean database + config)

Alright. Will clean the .pydio meta file from the buckets, to ensure they’re completely reset too.

Ps. in regards to the S3 datasource, it seems to be able to find it no problem, as it creates the “folders” in the bucket and adds a .pydio meta-file to each “folder”. But maybe one of the microservices has a prefix or something?

I’ll try to sync with a regular disk workspace first though, and then move it over to the S3 buckets afterwards

Good plan! When the cells server is running, first try to up- and download files on the web interface. Then, set up the sync client. If you have problems with the sync client, try to connect directly to the server (without the proxy).


This has been solved, there was a few caveats that the people at Pydio were kind enough to help me figure out.

  1. When using Let’sEncrypt, the external URL should be like this: https://domain.com and the internal url should be like this: domain.com:443

  2. Currently an internalPath with S3 is unsupported or results in a bug. I am not sure if this is written anywhere, but it was observed as we set it up.

If you run into any similar issues, hit me up and I’ll see if I can help you out.


1 Like