# \[Solved\] Failed to init DB provider	{"error": "Error 1709: Index column size too large. The maximum column size is 767 bytes. handling idm\_acl\_0.1.sql"}

**URL:** https://forum.pydio.com/t/solved-failed-to-init-db-provider-error-error-1709-index-column-size-too-large-the-maximum-column-size-is-767-bytes-handling-idm-acl-0-1-sql/1665
**Category:** Pydio Cells
**Created:** [October 4, 2018, 2:36pm UTC](https://forum.pydio.com/t/solved-failed-to-init-db-provider-error-error-1709-index-column-size-too-large-the-maximum-column-size-is-767-bytes-handling-idm-acl-0-1-sql/1665 "2018-10-04T14:36:41Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![kingfisher77](https://yyz2.discourse-cdn.com/flex032/user_avatar/forum.pydio.com/kingfisher77/32/258_2.png) [@kingfisher77](https://forum.pydio.com/u/kingfisher77)
#### Post date: [October 4, 2018, 2:36pm UTC](https://forum.pydio.com/t/solved-failed-to-init-db-provider-error-error-1709-index-column-size-too-large-the-maximum-column-size-is-767-bytes-handling-idm-acl-0-1-sql/1665/1 "2018-10-04T14:36:41Z")

</div>

we were curious about cells especially for the installation procedure which was announced as easy. But it is still “pydioesque” 🙂

We run latest debian with latest mariadb, everything out of the box. We followed the installation guide for debian and now we got stuck here:

`2018-10-04T16:31:14.138+0200	ERROR	pydio.grpc.acl	Failed to init DB provider	{"error": "Error 1709: Index column size too large. The maximum column size is 767 bytes. handling idm_acl_0.1.sql"}`

Followed diverse suggestions to pimp mariadb:

```
[mysqld]
innodb_file_format = Barracuda
innodb_file_per_table = 1
innodb_large_prefix = on

```

with no luck.

What do we miss?

---

<div class="post-metadata">

### Author: ![zayn](https://avatars.discourse-cdn.com/v4/letter/z/a87d85/32.png) [@zayn](https://forum.pydio.com/u/zayn)
#### Post date: [October 4, 2018, 2:37pm UTC](https://forum.pydio.com/t/solved-failed-to-init-db-provider-error-error-1709-index-column-size-too-large-the-maximum-column-size-is-767-bytes-handling-idm-acl-0-1-sql/1665/2 "2018-10-04T14:37:57Z")

</div>

Hi,  
what is your mariadb and pydio cells version?  
i need the exact numbers if possible to investigate that.

---

<div class="post-metadata">

### Author: ![kingfisher77](https://yyz2.discourse-cdn.com/flex032/user_avatar/forum.pydio.com/kingfisher77/32/258_2.png) [@kingfisher77](https://forum.pydio.com/u/kingfisher77)
#### Post date: [October 4, 2018, 2:50pm UTC](https://forum.pydio.com/t/solved-failed-to-init-db-provider-error-error-1709-index-column-size-too-large-the-maximum-column-size-is-767-bytes-handling-idm-acl-0-1-sql/1665/3 "2018-10-04T14:50:19Z")

</div>

```
root@cells:~ # mysql --version
mysql Ver 15.1 Distrib 10.1.26-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

root@cells:~ # /srv/web/cells/cells version

    Pydio Cells Home Edition (1.2.0)
    Published on 02 Oct 18 10:22 +0000
    Revision number 70deb1a17c7d17743c495526de767b82b7e8b10d
```

---

<div class="post-metadata">

### Author: ![zayn](https://avatars.discourse-cdn.com/v4/letter/z/a87d85/32.png) [@zayn](https://forum.pydio.com/u/zayn)
#### Post date: [October 4, 2018, 2:51pm UTC](https://forum.pydio.com/t/solved-failed-to-init-db-provider-error-error-1709-index-column-size-too-large-the-maximum-column-size-is-767-bytes-handling-idm-acl-0-1-sql/1665/4 "2018-10-04T14:51:54Z")

</div>

i see,  
could you upgrade mariadb to atleast version 10.2 and latest is 10.3.  
here’s the [requirement](https://pydio.com/en/docs/cells/v1/requirements) page if you need more details.

---

<div class="post-metadata">

### Author: ![zayn](https://avatars.discourse-cdn.com/v4/letter/z/a87d85/32.png) [@zayn](https://forum.pydio.com/u/zayn)
#### Post date: [October 4, 2018, 2:55pm UTC](https://forum.pydio.com/t/solved-failed-to-init-db-provider-error-error-1709-index-column-size-too-large-the-maximum-column-size-is-767-bytes-handling-idm-acl-0-1-sql/1665/5 "2018-10-04T14:55:49Z")

</div>

here’s the mariadb offical repository if you need,

[https://downloads.mariadb.org/mariadb/repositories/#distro=Ubuntu&version=10.3&mirror=cnrs](https://downloads.mariadb.org/mariadb/repositories/#distro=Ubuntu&version=10.3&mirror=cnrs)

you can change to debian and your version don’t worry!  
i’m going to update the documentation about that.

---

<div class="post-metadata">

### Author: ![kingfisher77](https://yyz2.discourse-cdn.com/flex032/user_avatar/forum.pydio.com/kingfisher77/32/258_2.png) [@kingfisher77](https://forum.pydio.com/u/kingfisher77)
#### Post date: [October 4, 2018, 3:32pm UTC](https://forum.pydio.com/t/solved-failed-to-init-db-provider-error-error-1709-index-column-size-too-large-the-maximum-column-size-is-767-bytes-handling-idm-acl-0-1-sql/1665/6 "2018-10-04T15:32:13Z")

</div>

Thank you, now it works. Thought latest from a current distro should work. But latest stable with custom repo is fine off course.

Thank you!

---

<div class="post-metadata">

### Author: ![zayn](https://avatars.discourse-cdn.com/v4/letter/z/a87d85/32.png) [@zayn](https://forum.pydio.com/u/zayn)
#### Post date: [October 11, 2018, 2:04pm UTC](https://forum.pydio.com/t/solved-failed-to-init-db-provider-error-error-1709-index-column-size-too-large-the-maximum-column-size-is-767-bytes-handling-idm-acl-0-1-sql/1665/7 "2018-10-11T14:04:15Z")

</div>


