# Pydio.grpc.user-meta won't start after uprade to 1.6.0

**URL:** <https://forum.pydio.com/t/pydio-grpc-user-meta-wont-start-after-uprade-to-1-6-0/2607>\
**Category:** Pydio Cells\
**Created:** [July 6, 2019, 5:38pm UTC](https://forum.pydio.com/t/pydio-grpc-user-meta-wont-start-after-uprade-to-1-6-0/2607 "2019-07-06T17:38:35Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![manfer](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@manfer](https://forum.pydio.com/u/manfer)\
**Post date:** [July 6, 2019, 5:38pm UTC](https://forum.pydio.com/t/pydio-grpc-user-meta-wont-start-after-uprade-to-1-6-0/2607/1 "2019-07-06T17:38:35Z")

</div>

I have update Pydio Cells Home Edition to 1.6.0 from webUI and now pydio.grpc.user-meta won’t start.

## In the logs I see this when cells is started.

## {“level”:“info”,“ts”:“2019-07-06T19:26:28+02:00”,“logger”:“pydio.grpc.user-meta”,“msg”:“started”} {“level”:“info”,“ts”:“2019-07-06T19:26:28+02:00”,“logger”:“pydio.grpc.user-meta”,“msg”:“Inserting default namespace for metadata”} {“level”:“error”,“ts”:“2019-07-06T19:26:28+02:00”,“logger”:“pydio.grpc.user-meta”,“msg”:“could not initialise service at version 1.6.0”,“error”:“Error 1062: Duplicate entry ‘usermeta-tags’ for key ‘namespace’”} {“level”:“error”,“ts”:“2019-07-06T19:26:28+02:00”,“logger”:“pydio.grpc.user-meta”,“msg”:"Could not run ",“error”:“Error 1062: Duplicate entry ‘usermeta-tags’ for key ‘namespace’”} {“level”:“info”,“ts”:“2019-07-06T19:26:28+02:00”,“logger”:“pydio.grpc.user-meta”,“msg”:“stopping”}

How can I solve this?

Thanks.

---

<div class="post-metadata">

**Author:** ![manfer](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@manfer](https://forum.pydio.com/u/manfer)\
**Post date:** [July 6, 2019, 6:38pm UTC](https://forum.pydio.com/t/pydio-grpc-user-meta-wont-start-after-uprade-to-1-6-0/2607/2 "2019-07-06T18:38:01Z")

</div>

I don’t know what is the problem. I don’t use any metadata I think. Just in case it is useful.

* * *

MariaDB [cells]\> select \* from idm\_usr\_meta;  
Empty set (0.001 sec)

MariaDB [cells]\> select \* from idm\_usr\_meta\_ns;  
±--------------±----------±---------±----------±----------------+  
| namespace | label | ns\_order | indexable | definition |  
±--------------±----------±---------±----------±----------------+  
| bookmark | Bookmarks | 0 | 0 | |  
| usermeta-tags | Tags | 0 | 1 | {“type”:“tags”} |  
±--------------±----------±---------±----------±----------------+  
2 rows in set (0.000 sec)

## MariaDB [cells]\> select \* from idm\_usr\_meta\_policies; ±—±--------------±-------±--------±-------±-----------+ | id | resource | action | subject | effect | conditions | ±—±--------------±-------±--------±-------±-----------+ | 1 | bookmark | READ | \* | allow | | | 2 | bookmark | WRITE | \* | allow | | | 3 | usermeta-tags | READ | \* | allow | | | 4 | usermeta-tags | WRITE | \* | allow | | ±—±--------------±-------±--------±-------±-----------+ 4 rows in set (0.000 sec)

---

<div class="post-metadata">

**Author:** ![manfer](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@manfer](https://forum.pydio.com/u/manfer)\
**Post date:** [July 6, 2019, 7:14pm UTC](https://forum.pydio.com/t/pydio-grpc-user-meta-wont-start-after-uprade-to-1-6-0/2607/3 "2019-07-06T19:14:37Z")

</div>

Ok. I knnow nothing about the project but I decided to try the solution that seemed logical reading the error messages and the database data.

So I did a backup of those tables and deleted from table idm\_usr\_meta\_ns the row which namespace value is usermeta-tags. Then restarted pydio cells and all is working again.

I did nothing on the table idm\_usr\_meta\_policies.

Hope it is the correct solution.

---

<div class="post-metadata">

**Author:** ![manfer](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@manfer](https://forum.pydio.com/u/manfer)\
**Post date:** [July 6, 2019, 7:22pm UTC](https://forum.pydio.com/t/pydio-grpc-user-meta-wont-start-after-uprade-to-1-6-0/2607/4 "2019-07-06T19:22:08Z")

</div>

I read the table idm\_usr\_meta\_policies again and I saw duplicates of the usermeta-tags READ and WRITE permission rows, so I deleted them.

---

<div class="post-metadata">

**Author:** ![zayn](https://avatars.discourse-cdn.com/v4/letter/z/a87d85/32.png) [@zayn](https://forum.pydio.com/u/zayn)\
**Post date:** [July 8, 2019, 8:41am UTC](https://forum.pydio.com/t/pydio-grpc-user-meta-wont-start-after-uprade-to-1-6-0/2607/5 "2019-07-08T08:41:07Z")

</div>

Hi @manfer ,

Did you fix your error by deleting the duplicates?

By the way did you install Cells twice with the same database? the duplicates could be coming from this.

---

<div class="post-metadata">

**Author:** ![manfer](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@manfer](https://forum.pydio.com/u/manfer)\
**Post date:** [July 8, 2019, 1:34pm UTC](https://forum.pydio.com/t/pydio-grpc-user-meta-wont-start-after-uprade-to-1-6-0/2607/6 "2019-07-08T13:34:18Z")

</div>

The problem was the row with namespace usermeta-tags in idm\_usr\_meta\_ns table.

For some reason on start cells was trying to insert that row and failed. Because the column namespace must have a unique index and the row already existed.

Once I removed that row cells started the user-meta service correctly but It added the rows in the table idm\_usr\_meta\_policies too. That’s why those were duplicated.

I don’t know anything about the code of this project but I suppose it was just a database migration being triggered on start.

Before this problem appeared, I did an update from 1.5.1 to 1.5.2, then from 1.5.2 to 1.5.3, then from 1.5.3 to 1.6.0, one after the other. Maybe I did something wrong during the updates.

The duplicates on the policies table were not a problem, I just remove them because seems the correct thing to do.

---

<div class="post-metadata">

**Author:** ![zayn](https://avatars.discourse-cdn.com/v4/letter/z/a87d85/32.png) [@zayn](https://forum.pydio.com/u/zayn)\
**Post date:** [July 18, 2019, 10:43am UTC](https://forum.pydio.com/t/pydio-grpc-user-meta-wont-start-after-uprade-to-1-6-0/2607/7 "2019-07-18T10:43:33Z")

</div>

Hello @manfer,

Have you fixed your issue?
