Pydio cells not working


I’m not familiar with CentOS…but I think this article is of some help,


This work for CentOS7



Hi there, i have the same problem with debian9 - mysql-server
ulimit -n 8162 id
uid=1001(pydio) gid=1001(pydio) groups=1001(pydio)

$ ./cells install

Welcome to Pydio Cells Home Edition installation
Pydio Cells Home Edition will be configured to run on this machine. Make sure to prepare the following data

  • IPs and ports for binding the webserver to outside world
  • MySQL 5.6+ (or MariaDB equivalent) server access
    Pick your installation mode when you are ready.

:heavy_check_mark: Command line (performed in this terminal)
:heavy_check_mark: External Host (used to access this machine from outside world if it differs from Bind Host):
:heavy_check_mark: Disable SSL (not recommended)

Database Connection

:heavy_check_mark: TCP
:heavy_check_mark: Database Hostname: localhost
:heavy_check_mark: Database Port: 3306
:heavy_check_mark: Database Name: cells
:heavy_check_mark: Database User: pydio
:heavy_check_mark: Database Password (leave empty if not needed): ********
:heavy_check_mark: Successfully connected to the database

Frontend Configuration

:heavy_check_mark: Admin Login (leave passwords empty if an admin is already created): admin
:heavy_check_mark: Admin Password: ********
:heavy_check_mark: Confirm Password: ********

Advanced Settings

✗ There are some advanced settings for ports and initial data storage. Do you want to edit them:

Performing Installation

2019-01-22T17:49:03.342+0100 INFO Starting installation now {“bindUrl”: “(http)://”}
:heavy_check_mark: Created main database
:heavy_check_mark: Created default datasources
:heavy_check_mark: Configuration of gateway services
:heavy_check_mark: Creation of logs directory

:heavy_check_mark: Installation Finished: please restart with ‘./cells start’ command

$ ./cells start
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x28 pc=0xf8b90a]

goroutine 276 [running]:
/pydio/cells/vendor/*service).Init(0xc424861680, 0xc424932cc0, 0x8, 0x8, 0x24, 0x1)
/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x31a, 0xc4248e1800, 0x0, 0x0)
/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x529
/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0x1fe
created by
/opt/teamcity/agent/work/b7c550f2c973b54c/src/ +0xa3

Any idea ?
Many thanks


could you tell me the type of your installation, vps, virtual machine, … ?
and also do you have a private interface on your server?


Hi zayan, many thanks for the prompt reply.
Well, looks like a secondary network interface iwith an IP address is fully necessary to start cells for transparent proxy reason …

I have created a new one on the server and just now can start it :slight_smile:

Basically this server is a vmware box running over a ESX’s cluster.

We use to have NAT’s for host in DMZ - i’m new with this new code and starting project to move all our pydio plateforms (not so far from 25)

I will keep you in touch sure :wink:





Cells requires at least one private IP because one of its services - NAT requires this address. NAT is mostly for internal communication between services so it does not run with public IP.


Well, but I think it can be a loopback address, not any other private address…can’t it? Actually the latest micro/go-web will use a loopback address if there is no private addresses.