Pydio cells not working


#1

Hi,

i have some problem to start pydio cells.

After the installation and “./cells start” i have this output

panic: runtime error: invalid memory address or nil pointer dereference
** [signal SIGSEGV: segmentation violation code=0x1 addr=0x28 pc=0xf8928a]**


** goroutine 65 [running]:**

some hints?

Thanks

Michele


Help installing Pydio Cells on Ubuntu 16.04
#2

Hi,
it could be that you are lacking RAM and therefore the binary does that, could you give me your system specs, the os and also the php, mysql versions.


#3

hi,

OS: CentOS Linux 7.5.1804
RAM : 8GB
CPUs: 4
php : rh-php71-php-zip-7.1.8-1.el7.x86_64
rh-php71-php-fpm-7.1.8-1.el7.x86_64
rh-php71-runtime-1-1.el7.x86_64
rh-php71-php-json-7.1.8-1.el7.x86_64
rh-php71-php-gd-7.1.8-1.el7.x86_64
rh-php71-php-opcache-7.1.8-1.el7.x86_64
rh-php71-php-mbstring-7.1.8-1.el7.x86_64
rh-php71-php-common-7.1.8-1.el7.x86_64
rh-php71-php-intl-7.1.8-1.el7.x86_64
rh-php71-php-xml-7.1.8-1.el7.x86_64

mariadb :
rh-mariadb102-mariadb-config-10.2.8-5.el7.x86_64
rh-mariadb102-mariadb-10.2.8-5.el7.x86_64
mariadb-libs-5.5.56-2.el7.x86_64
rh-mariadb102-runtime-3.0-5.el7.x86_64
rh-mariadb102-mariadb-common-10.2.8-5.el7.x86_64
rh-mariadb102-mariadb-errmsg-10.2.8-5.el7.x86_64
rh-mariadb102-mariadb-server-10.2.8-5.el7.x86_64
rh-mariadb102-mariadb-server-utils-10.2.8-5.el7.x86_64


#4

everything seems meeting the requirements so it’s not the issue,
maybe you could try to do a clean re installation if it’s was a recent one, remove the the pydio folder located in ~/.config/, download the latest binary ( if it wasn’t already done, latest version is 1.0.0 clear the database that was created it was named cells by default.

edit : if you have data that you want to keep don’t forget to back the data.


#5

i already tried…twice.

i try again.

thanks


#6

My last try.

./cells install

Welcome to Pydio Cells Home Edition installation
Pydio Cells Home Edition will be configured to run on this machine. Make sure to prepare the following data

  • IPs and ports for binding the webserver to outside world
  • MySQL 5.6+ (or MariaDB equivalent) server access
  • PHP-FPM 7+ for running frontend
    Pick your installation mode when you are ready.

:heavy_check_mark: Command line (performed in this terminal)
:heavy_check_mark: Other: foo.foo:80
:heavy_check_mark: External Host (used to access this machine from outside world if it differs from Bind Host): foo.foo:80
:heavy_check_mark: Disable SSL (not recommended)

Database Connection

:heavy_check_mark: TCP
:heavy_check_mark: Database Hostname: localhost
:heavy_check_mark: Database Port: 3306
:heavy_check_mark: Database Name: cells
:heavy_check_mark: Database User: pydio
:heavy_check_mark: Database Password (leave empty if not needed): *****
:heavy_check_mark: Successfully connected to the database

Frontend Configuration

:heavy_check_mark: Php version detected: 7.1.8
:heavy_check_mark: PHP-FPM Listen Address was detected at localhost:9000. Is it correct: y
:heavy_check_mark: Admin Login (leave passwords empty if an admin is already created): admin
:heavy_check_mark: Admin Password: ********
:heavy_check_mark: Confirm Password: ********

Advanced Settings

✗ There are some advanced settings for ports and initial data storage. Do you want to edit them:

Performing Installation

2018-05-31T15:54:23.974+0200 INFO Starting installation now {“bindUrl”: “http://foo.foo:80”}
:heavy_check_mark: Created main database
:heavy_check_mark: Created default datasources
:heavy_check_mark: Configuration of gateway services
:heavy_check_mark: Deploying interface assets: this may take some time…
:heavy_check_mark: Deploying interface assets: 10% done…
:heavy_check_mark: Deploying interface assets: 20% done…
:heavy_check_mark: Deploying interface assets: 30% done…
:heavy_check_mark: Deploying interface assets: 40% done…
:heavy_check_mark: Deploying interface assets: 50% done…
:heavy_check_mark: Deploying interface assets: 60% done…
:heavy_check_mark: Deploying interface assets: 70% done…
:heavy_check_mark: Deploying interface assets: 80% done…
:heavy_check_mark: Deploying interface assets: 90% done…
2018-05-31T15:54:46.426+0200 INFO Extracted 8015 files for a total size of 95909460
:heavy_check_mark: Deploying interface assets: 100% done…
:heavy_check_mark: Interface assets: Copied 8015 files
Writing file /home/pydio/.config/pydio/cells/static/pydio/data/plugins/boot.conf/bootstrap.json
:heavy_check_mark: Created interface config files

:heavy_check_mark: Installation Finished: please restart with ‘./cells start’ command

[pydio@foo ~]$ ./cells start
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x28 pc=0xf8928a]

any suggestion?


#7

Hi,
could please send me the entire stack, i would like to see whats happening after this

you can omit the part after the cells install.


#8

Hi,

sorry for the late reply.

I switch to docker-compose and everything goes fine for the moment .

thx


#9

Same problem here: CentOS 7.5.1804 with 16GB RAM
Followed installation procedure: create user pydio with Bash shell, placed cells/cells-ctl into home directory

[root@web7 /volume/home/pydio]# su pydio
[pydio@web7 ~]$ ./cells install

:heavy_check_mark: Installation Finished: please restart with ‘./cells start’ command

[pydio@web7 ~]$ ./cells start
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x28 pc=0xfb2a0a]

goroutine 103 [running]:
github.com/pydio/cells/vendor/github.com/micro/go-web.(*service).Init(0xc42494b040, 0xc4249e04c0, 0x7, 0x7, 0x24, 0x1)
/opt/JetBrains/TeamCity/buildAgent/work/73afa92fb1a910b1/src/github.com/pydio/cells/vendor/github.com/micro/go-web/service.go:298 +0x31a
github.com/pydio/cells/common/service.WithWeb.func1.2(0x5f954c0, 0xc424942c00, 0x0, 0x0)

REMARKS:

  • I have no /opt/JetBrains/…
  • Verified database credentials, but database has no tables (MariaDB 10.3.7)

Any ideas?


#10

End of stack trace:

github.com/pydio/cells/common/service.(*service).Start(0xc424942c00)
/opt/JetBrains/TeamCity/buildAgent/work/73afa92fb1a910b1/src/github.com/pydio/cells/common/service/service.go:320 +0x20a
created by github.com/pydio/cells/cmd.glob..func20
/opt/JetBrains/TeamCity/buildAgent/work/73afa92fb1a910b1/src/github.com/pydio/cells/cmd/services-start.go:147 +0xa3

Sorry, as newbee I am not allowed to post more “links”.
I used the latest release version 1.0.1.


#11

I have tried to install pydio cells 1.0,0 1.0.1, and 1.0.2 on both Ubuntu 16.0.4 and 18.0.4 with no success.
Since I’m a new user I have masked the github reference with a “,” so that I can post the text.

pydio@cells:~$ ./cells start
2018-07-19T15:28:08.940-0400 INFO WARNING: File descriptor limit 1024 is too low for running Pydio Cells Home Edition in production. At least 8192 is recommended. Fix with “ulimit -n 8192”.
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x28 pc=0xfb544a]

goroutine 67 [running]:
github,com/pydio/cells/vendor/github,com/micro/go-web.(*service).Init(0xc42023f7c0, 0xc424c30b00, 0x7, 0x7, 0x24, 0x1)
/opt/JetBrains/TeamCity/buildAgent/work/73afa92fb1a910b1/src/github.com/pydio/cells/vendor/github,com/micro/go-web/service.go:298 +0x31a
github,com/pydio/cells/common/service.WithWeb.func1.2(0x5fa1460, 0xc423598c00, 0x0, 0x0)
/opt/JetBrains/TeamCity/buildAgent/work/73afa92fb1a910b1/src/github,com/pydio/cells/common/service/service-web.go:83 +0x4ba
github,com/pydio/cells/common/service.(*service).Start(0xc423598c00)
/opt/JetBrains/TeamCity/buildAgent/work/73afa92fb1a910b1/src/github,com/pydio/cells/common/service/service.go:320 +0x20a
created by github,com/pydio/cells/cmd.glob…func20
/opt/JetBrains/TeamCity/buildAgent/work/73afa92fb1a910b1/src/github,com/pydio/cells/cmd/services-start.go:147 +0xa3
pydio@cells:~$


#12

I did some additional testing on this issue today. I only receive this error when attempting an installation using an outside world ip address . If I create a server using private ip address the installation works. I would like to know of those who have posted in this thread are using outside world ip addresses to help narrow this issue down.


#13

Interesting… I’ve received the same error on an 18.4 installation and using an external IP. So you’re saying it works if you install an internal IP… but then I guess access would only be available when in the local network?

I have this installed on a dedi box, and external access is a must have for me. I wonder if there’s any way to get it installed and accessible externally.


#14

I did additional testing yesterday and here are my findings. My setup is a VMWare ESXi host that can be accessed internally and externally. My first attempts were to install in a VM that was for external use only. The installation completes successfully but fails on startup with the error listed in this thread. I’ve tried binding to local host/outside ip and outside ip/outside ip and this error occurs everytime. If I install the VM for private use only the server start is successful every time with all features I’ve tested working. My gut feeling tells me it’s a GO Lang / NATS http redirect issue. I did the install one more time but when I configured the VM I installed it using two network adapters. I put one adapter private and one adapter public. When I did the bindings I used localhost:8080/Outside IP:8080 and the server successfully started but it is very slow. I also noticed that it’s not able to write any data to any folder as a user or as an admin. So in short, my best guess is some type of http redirect issue but I’ll leave that up to the developers to determine now that updated the post with this info.


#15

Working solution for me using an outside IP address in a virtual machine requires 2 network adapters. I can not make it work using only one. In the creation of my virtual machine I set one adapter for my internal network of 192.168.x.x and a set the other adapter for my real world network of 65.x.x.x . During the installation phase I set the internal listening IP address to my outside IP of 65.x.x.x:8080 and I also set the external listening port to my external IP of 65.x.x.x:8080 . I can connect using a web browser to url http://65.x.x.x.:8080 . Everything works now including writing data to folders which was failing before. If I log in as an admin and look at the Services it shows ALL services bound to the internal network of 192.168.x.x . If I try to connect to url http://192.168.x.x:8080 from the local network I get the error 404 Site 192.168.x.x:8080 is not served on this interface. I hope this helps others solve running Cells on a real world IP in a virtual machine. I’m very confident that trying to use an outside IP address using a single network adapter results in the panic:runtime errors due to some type of http redirect / NAT issue.


#16

This is great that you got it working! So it requires two adapters like enp0s1 and enp0s2?


#17

In my particular setup…Yes.


#18

I was using a single and public IP address as well. Added a second adapter with a local IP (192.168) and now it runs!
cells seems to bind to 127.0.0.1 and 0.0.0.0. Odd that it really needs some local IP.
I hope that can be fixed.


Networking issues on Ubuntu Server