New Install - Can't Access External

I’m new to Pydio, and to Cells. I like the new and improved design though (as I’ve looked at the older version a year or two ago). Anyway, I’m trying to install Pydio Cells on a fresh Ubuntu 18.04 EC2 instance from AWS. I’m not using SSL on the server itself as SSL is served by Amazon. I am however, unable to access the site after a fresh install on a clean server. I followed the guide for 1.2.5

Internal host: localhost:80
External host: sub.domain.com
Datasource: /mnt/cloud (this is a 100 GB volume)
Other ports: Left the same
Open ports for server: 80, 443

When trying to visit the site, I receive the following message:

[INFO] 10.0.2.139 - No such site at :80 (Remote: 10.0.0.174, Referer: )

The only error-like message in the log after initiating ./cells start is the following:

2019-01-12T15:37:06.505Z INFO pydio.rest.update started
2019-01-12T15:37:08.762Z INFO pydio.rest.share started
2019-01-12T15:37:15.982Z INFO Restarting Gateway Proxy {“caddyfile”: “\n\t\thttp://localhost:80 {\n\t\tproxy /a 10.0.2.56:35027 {\n\t\t\twithout /a\n\t\t\ttransparent\n\t\t}\n\t\tproxy /auth/dex 10.0.2.56:41541 {\n\t\t\ttransparent\n\t\t\tinsecure_skip_verify\n\t\t}\n\t\tproxy /io :42699 {\n\t\t\ttransparent\n\t\t}\n\t\tproxy /data :42699 {\n\t\t\ttransparent\n\t\t}\n\t\tproxy /ws 10.0.2.56:43063 {\n\t\t\twebsocket\n\t\t\twithout /ws\n\t\t}\n\t\tproxy /plug/ 10.0.2.56:46331 {\n\t\t\ttransparent\n\t\t\theader_downstream Cache-Control “public, max-age=31536000”\n\t\t}\n\t\tproxy /dav/ 10.0.2.56:43185 {\n\t\t\ttransparent\n\t\t}\n\n\t\tproxy /public/ 10.0.2.56:46331 {\n\t\t\ttransparent\n\t\t}\n\n\t\tproxy /user/reset-password/ 10.0.2.56:46331 {\n\t\t\ttransparent\n\t\t}\n\n\t\tproxy /robots.txt 10.0.2.56:46331 {\n\t\t\ttransparent\n\t\t}\n\n\t\tproxy /login 10.0.2.56:46331/gui {\n\t\t\ttransparent\n\t\t\twithout /login\n\t\t}\n\n\t\tredir 302 {\n\t\t if {path} is /\n\t\t / /login\n\t\t}\n\n\t\t\n\t\t\n proxy /wopi/ 10.0.2.56:44251 {\n transparent\n }\n\n proxy /loleaflet/ https[://]localhost:9980/loleaflet {\n transparent\n insecure_skip_verify\n without /loleaflet/\n }\n\n proxy /hosting/discovery https[://]localhost:9980/hosting/discovery {\n transparent\n insecure_skip_verify\n without /hosting/discovery\n }\n\n proxy /lool/ https[://]localhost:9980/lool/ {\n transparent\n insecure_skip_verify\n websocket\n without /lool/\n }\n \n\t\t\n\n\t\trewrite {\n\t\t\tif {path} not_starts_with “/a/”\n\t\t\tif {path} not_starts_with “/auth/”\n\t\t\tif {path} not_starts_with “/io”\n\t\t\tif {path} not_starts_with “/data”\n\t\t\tif {path} not_starts_with “/ws/”\n\t\t\tif {path} not_starts_with “/plug/”\n\t\t\tif {path} not_starts_with “/dav/”\n\t\t\t\n\t\t\tif {path} not_starts_with “/wopi/”\n\t\t\t\n\t\t\tif {path} not_starts_with “/loleaflet/”\n\t\t\t\n\t\t\tif {path} not_starts_with “/hosting/discovery”\n\t\t\t\n\t\t\tif {path} not_starts_with “/lool/”\n\t\t\t\n\t\t\tif {path} not_starts_with “/public/”\n\t\t\tif {path} not_starts_with “/user/reset-password”\n\t\t\tif {path} not_starts_with “/robots.txt”\n\t\t\tto {path} {path}/ /login\n\t\t}\n\n\t\t\n\t\terrors “/home/pydio/.config/pydio/cells/logs/caddy_errors.log”\n\t\t}\n\n\t\t\n\t”}
2019-01-12T15:37:15.982Z INFO [INFO] Reloading
2019-01-12T15:37:15.982Z INFO [INFO] Reloading complete
2019-01-12T15:37:15.982Z INFO Restart Finished
2019-01-12T15:37:15.982Z INFO http: Server closed
2019-01-12T15:37:34.401Z INFO [INFO] 10.0.2.56 - No such site at :80 (Remote: 10.0.0.174, Referer: )

HI,
could you try the following setting,
internal host sub.domain.com:80
external host sub.domain.com

Also i did not fully understand this, but do you mean that you use for install https://sub.domain.com to access your cells installation?

I thought I had tried that before. I had to go in and modify pydio.json afterwords because it used http by default instead of https, so that blocked resources from loading. I was also unaware that the username was case sensitive, which took a minute to figure out. My only question now is that I’m unable to login via the Desktop app. I can’t grab the error message because it’s thousands of lines on the app.

On the iPhone app (Lite), trying to enter the URL to connect to the server, I get an error saying the “Server is unreachable”

Hi,
unfortunately the desktop app is at the moment not compatible with cells but it’s on the way.

Did you remember to edit the security group in AWS for the server to allow traffic on port 80 and 443? Note, not the firewall in linux, but the AWS security group which is either selected or built for the vm when it is created? By default, only port 22 will be opened to allow SSH’ing into the box.

Mark