JWT Refresh stop upload large files when /a/frontend/session is called

Hey,

i have a fresh installation of pydio cells. I used the a nginx reserve proxy based on https://pydio.com/en/docs/kb/deployment/running-cells-behind-nginx-reverse-proxy. I can upload “small” files via the webfrontend or the cli client. But if upload a “large” file (it don`t depend on the file size, depend on the time i need to upload) it don’t work.

The upload works until the jwt need to be refreshed, after the api call to a/frontend/session the current upload failed (all parts, http status 403 and 502). After that the Webfrontend restart the upload with part1. Until the next session call is performed and it starts again…

If i use the cli i don’t know how to debug it. On the Server side i have the same logs as the web-gui upload. In the shell i got the following message (filename changed)

cec scp Video.mp4 cells://personal-files/Theater/
Uploading Video.mp4 to cells://personal-files/Theater/
52% [==================================>---------------------------------] Video.mp4
2020/07/19 00:05:55 [MultipartUpload: upload multipart failed
upload id: 0ff356f8-a921-4c50-9464-d42f2ecf6351
caused by: AccessDenied: Access Denied.
status code: 403, request id: , host id: ]

In the GUI i see the following output in the developer console (this is in chromium, i got the same message in firefox)

Pydio Cell Version:

Pydio Cells Home Edition
Version: 2.1.2
Built: 10 Jul 20 07:11 +0000
Git commit: 4f82e230e723c778e354f6e610ec2c4607ef502b
OS/Arch: linux/amd64
Go version: go1.13.12

Did soemone knows if it is a problem with the nginx reserve-proxy or how i can fix it. I seen in the internet™ that there are value in the pydio.json where i can change the jwt time but I dont have the values in my config.

Hey, I wonder if the problem is that your multipart uploads are timing out, the default timeout is 3 minutes. I had this issue myself and resolved it by increasing the timeout. I’m still using v2.0.9 and you’ll find the setting in that version under Cells Console->Plugins->Uploaders Options->Multipart Uploads->Request Timeout, I set it to 30 minutes and haven’t had issues since.

Hello @scott.bentley, @kekskurse,

Sorry for the late reply (as it is summer we are fewer).

@kekskurse could you tell me your current setup on your server, do you have a reverse proxy,

Also what version of the ./cec client are you using.

We have deployed a fix on the latest versions that will refresh the token during the upload which should not break the upload otherwise we would have to check what is happening on the server side.