# Failing to uploading 20GB on Pydio server, data corrupted

**URL:** <https://forum.pydio.com/t/failing-to-uploading-20gb-on-pydio-server-data-corrupted/663>\
**Category:** Pydio 8\
**Tags:** apache, php70, debian\
**Created:** [February 9, 2018, 12:16pm UTC](https://forum.pydio.com/t/failing-to-uploading-20gb-on-pydio-server-data-corrupted/663 "2018-02-09T12:16:33Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![TFujiwara](https://avatars.discourse-cdn.com/v4/letter/t/6a8cbe/32.png) [@TFujiwara](https://forum.pydio.com/u/TFujiwara)\
**Post date:** [February 9, 2018, 12:16pm UTC](https://forum.pydio.com/t/failing-to-uploading-20gb-on-pydio-server-data-corrupted/663/1 "2018-02-09T12:16:33Z")

</div>

Running Community Version on Debian 9.

Pydio fails uploading big files, i was uploading a 20GB VMware machine compressed.

I have solved half of the problem with making a symbolic link from the tmp folder on /var/www/html to my temp folder located in /home partition.

I have the data of the users divided via Debian users with a data folder writable for the apache user www-data in their home.

The problem is that Pydio fails uploading the whole 20GB, making the file corrupted.  
I’m using PLUploader for uploading files to the server.

---

<div class="post-metadata">

**Author:** ![zayn](https://avatars.discourse-cdn.com/v4/letter/z/a87d85/32.png) [@zayn](https://forum.pydio.com/u/zayn)\
**Post date:** [February 9, 2018, 1:12pm UTC](https://forum.pydio.com/t/failing-to-uploading-20gb-on-pydio-server-data-corrupted/663/2 "2018-02-09T13:12:25Z")

</div>

Hi,  
this issue might be because you didnt configure your php.ini file you should modify [those](https://gyazo.com/d569ae25d16bb8910a5e671088d4e569) values.  
If you want to find your php.ini you can use `php -i | grep "Loaded Configuration File"`.  
and then you can change the values to the ones that you need.

---

<div class="post-metadata">

**Author:** ![TFujiwara](https://avatars.discourse-cdn.com/v4/letter/t/6a8cbe/32.png) [@TFujiwara](https://forum.pydio.com/u/TFujiwara)\
**Post date:** [February 9, 2018, 4:31pm UTC](https://forum.pydio.com/t/failing-to-uploading-20gb-on-pydio-server-data-corrupted/663/3 "2018-02-09T16:31:30Z")

</div>

php.ini is well configured, i’ve modified those values properly.

![pydio](https://canada1.discourse-cdn.com/flex032/uploads/pydio/original/1X/a208f9b9e0d95edc1948cd4db5214862902e461a.PNG)

---

<div class="post-metadata">

**Author:** ![zayn](https://avatars.discourse-cdn.com/v4/letter/z/a87d85/32.png) [@zayn](https://forum.pydio.com/u/zayn)\
**Post date:** [February 12, 2018, 8:33am UTC](https://forum.pydio.com/t/failing-to-uploading-20gb-on-pydio-server-data-corrupted/663/4 "2018-02-12T08:33:16Z")

</div>

Hi,  
i dont know if you knew but you can edit PLUploader settings, here’s a [picture](https://prnt.sc/idii63) as an example.  
If there’s still an issue you could look at Pydio logs by doing this :  
Go to `conf/bootstrap_context.php`  
Switch this line to true :  
`define("AJXP_SERVER_DEBUG" , true);`
