# Cross-device mounts detected on path

**URL:** <https://forum.pydio.com/t/cross-device-mounts-detected-on-path/4952>\
**Category:** Pydio Cells\
**Tags:** install\
**Created:** [February 3, 2023, 2:49am UTC](https://forum.pydio.com/t/cross-device-mounts-detected-on-path/4952 "2023-02-03T02:49:08Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![mooncaptain](https://yyz2.discourse-cdn.com/flex032/user_avatar/forum.pydio.com/mooncaptain/32/1984_2.png) [@mooncaptain](https://forum.pydio.com/u/mooncaptain)\
**Post date:** [February 3, 2023, 2:49am UTC](https://forum.pydio.com/t/cross-device-mounts-detected-on-path/4952/1 "2023-02-03T02:49:08Z")

</div>

```auto
Level : info
Logger : pydio.grpc.data.objects.local2
Msg : ERROR Invalid command line arguments: Cross-device mounts detected on path (/media) at following locations [/media/media02]. Export path should not have any sub-mounts, refusing to start.
Ts : 1675391040
SpanUuid : span-5

```

This is a binary install.  
I am choosing the import data option.  
I have had the same problem trying to implement the flat option.  
There is a folder on the NAS already hence the import data option.

The mount instruction is: 192.168.0.19:/volume1/Media02 on /media/media02  
In case it matters this a synolgy nas ds220. I am also running smb on it so I can see the disk from my windows work station.

in addition I have tried mapping to just /mnt or /media - but I can see the interface requires a 2nd level.  
Also I tried a three level map such as /volume1/Media02 on /media/media02/top - this failed with the same error.

the media folder is owned by the user running cells - permission rwx for everybody  
the media02 folder is owned by the user running cells - permission rwx for everybody

Just as a point of comparison I mounted a usb drive at /media/usb-drive and I get the same error when creating a storage entry.

What should I be looking at next.

Thanks

---

<div class="post-metadata">

**Author:** ![mooncaptain](https://yyz2.discourse-cdn.com/flex032/user_avatar/forum.pydio.com/mooncaptain/32/1984_2.png) [@mooncaptain](https://forum.pydio.com/u/mooncaptain)\
**Post date:** [February 3, 2023, 7:05pm UTC](https://forum.pydio.com/t/cross-device-mounts-detected-on-path/4952/2 "2023-02-03T19:05:18Z")

</div>

```auto
Level : info
Logger : pydio.grpc.data.objects.local2
Msg : Error: Rename across devices not allowed, please fix your backend configuration (/opt/start/.minio.sys/tmp/9edbae8c-f266-4416-ba45-d31982976c61/d8dc6d6e-3cba-4db3-977d-22597c396aa2)->(/opt/start/datalink/.pydio) (*fmt.wrapError)
Ts : 1675450751
SpanUuid : span-8

```

I have come across a post on this site that recommended using links in the setup instead of the direct reference to the share folder assigned in the mount. I tried that and was able to get the service to run but it failed to sync the data with the above error.

I am really stuck here without the ability to connect to some large data store I will have to use a less desirable server application like own or next (cloud).

Any help will be appreciated.

---

<div class="post-metadata">

**Author:** ![mRguy](https://yyz2.discourse-cdn.com/flex032/user_avatar/forum.pydio.com/mrguy/32/2006_2.png) [@mRguy](https://forum.pydio.com/u/mRguy)\
**Post date:** [February 27, 2023, 12:43am UTC](https://forum.pydio.com/t/cross-device-mounts-detected-on-path/4952/3 "2023-02-27T00:43:16Z")

</div>

I run unraid. Used the linuxserver image, but mounted /config/data to a custom share. That seemed to work fine so I wanted to add a workspace for my media as well. I added a volume that points to the media share and tried adding a data source. Result is the same as what you have. It’s frustrating since I really like the software, but it is a very important feature for me.

---

<div class="post-metadata">

**Author:** ![mooncaptain](https://yyz2.discourse-cdn.com/flex032/user_avatar/forum.pydio.com/mooncaptain/32/1984_2.png) [@mooncaptain](https://forum.pydio.com/u/mooncaptain)\
**Post date:** [February 27, 2023, 3:33pm UTC](https://forum.pydio.com/t/cross-device-mounts-detected-on-path/4952/4 "2023-02-27T15:33:53Z")

</div>

> [@\[solved\] How to setup nfs share to a NAS device](https://forum.pydio.com/t/how-to-setup-nfs-share-to-a-nas-device/4957/5):
>
> To cover all the bases: On the Synology: On the Synology server setup the shared folder / NFS permissions to include the server Pydio is running on. On the NAS folder root I added a subfolder called base. On the Pydio box add a folder under /mnt called subfolder (for instance) change the owner for both folders to the user that runs cells. change the permissions on both folders to 777 you can trim these back after you get it working if you like. In the Cells Console add a Storage / Datasour…

---

<div class="post-metadata">

**Author:** ![system](https://canada1.discourse-cdn.com/flex032/uploads/pydio/original/2X/6/61f19fa52ec15fd4250db51aea351adba0e831fd.png) [@system](https://forum.pydio.com/u/system)\
**Post date:** [April 28, 2023, 3:34pm UTC](https://forum.pydio.com/t/cross-device-mounts-detected-on-path/4952/5 "2023-04-28T15:34:44Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
