# Changed Php settings not recognized by pydio

**URL:** <https://forum.pydio.com/t/changed-php-settings-not-recognized-by-pydio/1503>\
**Category:** Pydio 8\
**Tags:** php70\
**Created:** [August 25, 2018, 6:42pm UTC](https://forum.pydio.com/t/changed-php-settings-not-recognized-by-pydio/1503 "2018-08-25T18:42:41Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![tango13](https://avatars.discourse-cdn.com/v4/letter/t/53a042/32.png) [@tango13](https://forum.pydio.com/u/tango13)\
**Post date:** [August 25, 2018, 6:42pm UTC](https://forum.pydio.com/t/changed-php-settings-not-recognized-by-pydio/1503/1 "2018-08-25T18:42:41Z")

</div>

**pydio 8.2.1, linux, community edition, installed on shared server**

> hello ,my name is tom and i am new here.  
> i like pydio and use it since 2 years.  
> i searched the docu and this forum to get a hint for my issue, but…

i have an issue with my pydio 8.2.1 updating from 6.4.2  
seems i done something in the wrong order:

i updated php to 5.6 then updated pydio from 6.4.2 to 8.2.x

after detecting that some bigger file uploads need a change in php setting, i updated to php7.1  
and asked the admin team to set the php parameters: upload\_max\_filesize und post\_max\_size to their new values.(640M)

but it never works., always a failure comes up the file transfer was broken by too big file size  
no failure in log files. small files were ok !

if i call **pydio/ settings/ diagnose**.(please look at the end of this post)  
it tells me the old unchanged settings and a pydio 5.4 version  
in diverse folders are php.ini files located, but all with old values. i cannot detect where pydio is pulling the new php settings from.  
cache was cleared  
in **pydio/settings/uploader** : settings for files size 640M and maxupload set to ZERO and simultanous 50 files

so to help me, my admins installed a new pydio in parallel for testing reason and the php parameters and version were recognized perfectly by it.

_ **My issue,** _ i dont want to loose my shares, files, mysql database etc. because many people use my shared files…

**so my question here:**  
is the a way to get it solved without a new installation?

**second question** , is this middlware secure token error a problem? i see no blocking in using pydio…

> 08-24-18 17:16:30 89.107.64.170 ERROR shared SecureTokenMiddleware.php error l.70 message=You are not allowed to access this resource.  
> 08-24-18 17:16:36 89.107.64.170 INFO support-test Pydio\Core\Services\AuthService Log In context=WebUI  
> 08-24-18 17:16:37 89.107.64.170 INFO support-test editor.diaporama Preview Preview content of /2018-08-24 09\_12\_17-File Manager.png files=/2018-08-24 09\_12\_17-File Manager.png  
> 08-24-18 17:16:53 89.107.64.170 INFO support-test conf.sql Switch Repository rep. id=ajxp\_conf  
> 08-24-18 17:17:08 89.107.64.170 INFO support-test Pydio\Core\Services\AuthService Log In context=WebUI  
> 08-24-18 17:17:09 89.107.64.170 INFO support-test editor.diaporama Preview Preview content of /2018-08-24 09\_12\_17-File Manager.png files=/2018-08-24 09\_12\_17-File Manager.png  
> 08-24-18 17:17:26 89.107.64.170 INFO support-test access.fs Upload File file=my-files//test2.dat;files=my-files//test2.dat  
> 08-24-18 17:20:51 89.107.64.170 ERROR shared SecureTokenMiddleware.php error l.70 message=You are not allowed to access this resource.
> 
> > Blockquote

\*\*

> diagnose output  
> Client : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36 OPR/54.0.2952.64  
> Command Line Available : Yes  
> DOM Enabled : Yes  
> Exif Enabled : Yes  
> GD Enabled : Yes  
> Upload Max Size : 128M  
> Memory Limit : 512M  
> Max execution time : 300  
> Safe Mode : 0  
> Safe Mode GID : 0  
> Xml parser enabled : 1  
> MCrypt Enabled : Yes  
> Server OS : Linux  
> Session Save Path : /var/lib/php5/sessions  
> Session Save Path Writeable : No  
> PHP Version : 5.4.45  
> Locale : C  
> Directory Separator : /  
> PHP APC extension loaded : Yes  
> PHP INTL extension loaded : Yes  
> PHP Output Buffer disabled : No  
> PHP File Uploads enabled : Yes  
> Magic quotes disabled : Yes  
> Upload Tmp Dir Writeable : Yes  
> PHP Upload Max Size : 134217728  
> PHP Post Max Size : 134217728  
> Users enabled : Yes  
> Guest enabled : No  
> Writeable Folders : [ **cache** :true,  
> **data** :true]  
> Zlib Enabled : Yes

\*\*  
thank you in advance for advice and help  
sincerely Thomas

---

<div class="post-metadata">

**Author:** ![c12simple](https://yyz2.discourse-cdn.com/flex032/user_avatar/forum.pydio.com/c12simple/32/90_2.png) [@c12simple](https://forum.pydio.com/u/c12simple)\
**Post date:** [August 27, 2018, 7:07am UTC](https://forum.pydio.com/t/changed-php-settings-not-recognized-by-pydio/1503/2 "2018-08-27T07:07:36Z")

</div>

Hi,

If you are using apache as web server, it’s usually the lack of php71 (or php-php71) package. This package will install a module of Apache.

---

<div class="post-metadata">

**Author:** ![tango13](https://avatars.discourse-cdn.com/v4/letter/t/53a042/32.png) [@tango13](https://forum.pydio.com/u/tango13)\
**Post date:** [August 27, 2018, 11:32am UTC](https://forum.pydio.com/t/changed-php-settings-not-recognized-by-pydio/1503/4 "2018-08-27T11:32:20Z")

</div>

thanxs Tran,

```
  i got from the server team the response: its a linux server with debian 8

```

no glue what they use as webserver

sincerely Thomas
